p PatchFirst

CVE-2020-15704

CVE-2020-15704 · pppd arbitrary file read information disclosure vulnerability

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

CVSS 5.5 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • ppp

    Versions du logiciel
    • ≥ 2.4.5, < 2.4.5-5ubuntu1.4: Concernée; ≥ 2.4.5-5.1ubuntu2.3+esm2: Non concernée (custom)
    • ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3: Concernée; ≥ 2.4.7-2+2ubuntu1.3: Non concernée; ≥ 2.4.7-2+4.1ubuntu5.1: Non concernée; ≥ 2.4.7-2+4.1ubuntu6: Non concernée (custom)

    Mettez à jour vers 2.4.5-5.1ubuntu2.3+esm2; Mettez à jour vers 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 2.4.5-5.1ubuntu2
    • 2.4.5-5.1ubuntu2.1
    • 2.4.5-5.1ubuntu2.2
    • 2.4.5-5.1ubuntu2.3
    • 2.4.5-5.1ubuntu2.3+esm1
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.5-5.1ubuntu2.3+esm2

    Mettez à jour vers 2.4.5-5.1ubuntu2.3+esm2

  • ppp Ubuntu:16.04:LTS

    Versions du logiciel
    • 2.4.6-3.1ubuntu1
    • 2.4.7-1+1ubuntu1
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+2ubuntu1.16.04.1
    • 2.4.7-1+2ubuntu1.16.04.2
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.7-1+2ubuntu1.16.04.3

    Mettez à jour vers 2.4.7-1+2ubuntu1.16.04.3

  • ppp Ubuntu:18.04:LTS

    Versions du logiciel
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+4ubuntu1
    • 2.4.7-1+4ubuntu3
    • 2.4.7-2+1ubuntu1
    • 2.4.7-2+2ubuntu1
    • 2.4.7-2+2ubuntu1.1
    • 2.4.7-2+2ubuntu1.2
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.7-2+2ubuntu1.3

    Mettez à jour vers 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:20.04:LTS

    Versions du logiciel
    • 2.4.7-2+4.1ubuntu4
    • 2.4.7-2+4.1ubuntu5
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.7-2+4.1ubuntu5.1

    Mettez à jour vers 2.4.7-2+4.1ubuntu5.1

Sources originales

Vérifiez votre serveur →