p PatchFirst

CVE-2020-15704

CVE-2020-15704 · pppd arbitrary file read information disclosure vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

CVSS 5.5 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • ppp

    Softwareversionen
    • ≥ 2.4.5, < 2.4.5-5ubuntu1.4: Betroffen; ≥ 2.4.5-5.1ubuntu2.3+esm2: Nicht betroffen (custom)
    • ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3: Betroffen; ≥ 2.4.7-2+2ubuntu1.3: Nicht betroffen; ≥ 2.4.7-2+4.1ubuntu5.1: Nicht betroffen; ≥ 2.4.7-2+4.1ubuntu6: Nicht betroffen (custom)

    Auf 2.4.5-5.1ubuntu2.3+esm2 aktualisieren; Auf 2.4.7-2+2ubuntu1.3 aktualisieren

  • ppp Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 2.4.5-5.1ubuntu2
    • 2.4.5-5.1ubuntu2.1
    • 2.4.5-5.1ubuntu2.2
    • 2.4.5-5.1ubuntu2.3
    • 2.4.5-5.1ubuntu2.3+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.5-5.1ubuntu2.3+esm2

    Auf 2.4.5-5.1ubuntu2.3+esm2 aktualisieren

  • ppp Ubuntu:16.04:LTS

    Softwareversionen
    • 2.4.6-3.1ubuntu1
    • 2.4.7-1+1ubuntu1
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+2ubuntu1.16.04.1
    • 2.4.7-1+2ubuntu1.16.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.7-1+2ubuntu1.16.04.3

    Auf 2.4.7-1+2ubuntu1.16.04.3 aktualisieren

  • ppp Ubuntu:18.04:LTS

    Softwareversionen
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+4ubuntu1
    • 2.4.7-1+4ubuntu3
    • 2.4.7-2+1ubuntu1
    • 2.4.7-2+2ubuntu1
    • 2.4.7-2+2ubuntu1.1
    • 2.4.7-2+2ubuntu1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.7-2+2ubuntu1.3

    Auf 2.4.7-2+2ubuntu1.3 aktualisieren

  • ppp Ubuntu:20.04:LTS

    Softwareversionen
    • 2.4.7-2+4.1ubuntu4
    • 2.4.7-2+4.1ubuntu5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.4.7-2+4.1ubuntu5.1

    Auf 2.4.7-2+4.1ubuntu5.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →