CVE-2020-15704
CVE-2020-15704 · pppd arbitrary file read information disclosure vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
CVSS 5.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ppp
- Versions
- ≥ 2.4.5, < 2.4.5-5ubuntu1.4: Affected; ≥ 2.4.5-5.1ubuntu2.3+esm2: Not affected (custom)
- ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3: Affected; ≥ 2.4.7-2+2ubuntu1.3: Not affected; ≥ 2.4.7-2+4.1ubuntu5.1: Not affected; ≥ 2.4.7-2+4.1ubuntu6: Not affected (custom)
Update to 2.4.5-5.1ubuntu2.3+esm2; Update to 2.4.7-2+2ubuntu1.3
ppp Ubuntu:Pro:14.04:LTS
- Versions
- 2.4.5-5.1ubuntu2
- 2.4.5-5.1ubuntu2.1
- 2.4.5-5.1ubuntu2.2
- 2.4.5-5.1ubuntu2.3
- 2.4.5-5.1ubuntu2.3+esm1
- Affected ranges
- ECOSYSTEM: < 2.4.5-5.1ubuntu2.3+esm2
Update to 2.4.5-5.1ubuntu2.3+esm2
ppp Ubuntu:16.04:LTS
- Versions
- 2.4.6-3.1ubuntu1
- 2.4.7-1+1ubuntu1
- 2.4.7-1+2ubuntu1
- 2.4.7-1+2ubuntu1.16.04.1
- 2.4.7-1+2ubuntu1.16.04.2
- Affected ranges
- ECOSYSTEM: < 2.4.7-1+2ubuntu1.16.04.3
Update to 2.4.7-1+2ubuntu1.16.04.3
ppp Ubuntu:18.04:LTS
- Versions
- 2.4.7-1+2ubuntu1
- 2.4.7-1+4ubuntu1
- 2.4.7-1+4ubuntu3
- 2.4.7-2+1ubuntu1
- 2.4.7-2+2ubuntu1
- 2.4.7-2+2ubuntu1.1
- 2.4.7-2+2ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 2.4.7-2+2ubuntu1.3
Update to 2.4.7-2+2ubuntu1.3
ppp Ubuntu:20.04:LTS
- Versions
- 2.4.7-2+4.1ubuntu4
- 2.4.7-2+4.1ubuntu5
- Affected ranges
- ECOSYSTEM: < 2.4.7-2+4.1ubuntu5.1
Update to 2.4.7-2+4.1ubuntu5.1