p PatchFirst

CVE-2023-28104

CVE-2023-28104 · silverstripe/graphql Denial of Service vulnerability

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.

CVSS 7.5 · Élevée · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • silverstripe-graphql

    Versions du logiciel
    • = 4.1.1: Concernée
    • = 4.2.2: Concernée

    Aucun correctif publié

  • silverstripe/graphql Packagist

    Versions du logiciel
    • 4.1.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.1.1, < 4.1.2

    Mettez à jour vers 4.1.2

  • silverstripe/graphql Packagist

    Versions du logiciel
    • 4.2.2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.2.2, < 4.2.3

    Mettez à jour vers 4.2.3

Sources originales

Vérifiez votre serveur →