p PatchFirst

CVE-2023-28104

CVE-2023-28104 · silverstripe/graphql Denial of Service vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.

CVSS 7.5 · Hoch · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • silverstripe-graphql

    Softwareversionen
    • = 4.1.1: Betroffen
    • = 4.2.2: Betroffen

    Keine Korrektur veröffentlicht

  • silverstripe/graphql Packagist

    Softwareversionen
    • 4.1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.1.1, < 4.1.2

    Auf 4.1.2 aktualisieren

  • silverstripe/graphql Packagist

    Softwareversionen
    • 4.2.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.2.2, < 4.2.3

    Auf 4.2.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →