CVE-2023-28104
CVE-2023-28104 · silverstripe/graphql Denial of Service vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.
CVSS 7.5 · High · EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe-graphql
- Versions
- = 4.1.1: Affected
- = 4.2.2: Affected
No fix published
silverstripe/graphql Packagist
- Versions
- 4.1.1
- Affected ranges
- ECOSYSTEM: ≥ 4.1.1, < 4.1.2
Update to 4.1.2
silverstripe/graphql Packagist
- Versions
- 4.2.2
- Affected ranges
- ECOSYSTEM: ≥ 4.2.2, < 4.2.3
Update to 4.2.3
Original sources
- https://github.com/silverstripe/silverstripe-graphql/security/advisories/GHSA-67g8-c724-8mp3
- https://github.com/silverstripe/silverstripe-graphql/pull/526
- https://github.com/silverstripe/silverstripe-graphql/releases/tag/4.1.2
- https://github.com/silverstripe/silverstripe-graphql/releases/tag/4.2.3
- https://nvd.nist.gov/vuln/detail/CVE-2023-28104