p PatchFirst

CVE-2023-6349

CVE-2023-6349 · Heap overflow in libvpx

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A heap overflow vulnerability exists in libvpx - Encoding a frame that has larger dimensions than the originally configured size with VP9 may result in a heap overflow in libvpx. We recommend upgrading to version 1.13.1 or above

CVSS 5.7 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libvpx

    Versions du logiciel
    • ≥ 1.5.0, < 1.13.1: Concernée (semver)

    Mettez à jour vers 1.13.1

  • libvpx Debian:12

    Versions du logiciel
    • 1.12.0-1
    • 1.12.0-1+deb12u1
    Plages de versions concernées
    • ECOSYSTEM: < 1.12.0-1+deb12u2

    Mettez à jour vers 1.12.0-1+deb12u2

  • libvpx Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.13.1-2

    Mettez à jour vers 1.13.1-2

  • libvpx Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.13.1-2

    Mettez à jour vers 1.13.1-2

  • libvpx Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 1.2.0-2
    • 1.3.0-1
    • 1.3.0-2
    • 1.3.0-2ubuntu0.1~esm1
    • 1.3.0-2ubuntu0.1~esm2
    • 1.3.0-2ubuntu0.1~esm3
    • 1.3.0-2ubuntu0.1+esm3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libvpx Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.4.0-4
    • 1.5.0-2
    • 1.5.0-2ubuntu1
    • 1.5.0-2ubuntu1.1
    • 1.5.0-2ubuntu1.1+esm1
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.0-2ubuntu1.1+esm2

    Mettez à jour vers 1.5.0-2ubuntu1.1+esm2

  • libvpx Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.6.1-3
    • 1.7.0-3
    • 1.7.0-3ubuntu0.18.04.1
    Plages de versions concernées
    • ECOSYSTEM: < 1.7.0-3ubuntu0.18.04.1+esm1

    Mettez à jour vers 1.7.0-3ubuntu0.18.04.1+esm1

  • libvpx Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.8.1-2
    • 1.8.2-1
    • 1.8.2-1build1
    Plages de versions concernées
    • ECOSYSTEM: < 1.8.2-1ubuntu0.2

    Mettez à jour vers 1.8.2-1ubuntu0.2

  • libvpx Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.9.0-1ubuntu1
    • 1.11.0-2ubuntu1
    • 1.11.0-2ubuntu2
    Plages de versions concernées
    • ECOSYSTEM: < 1.11.0-2ubuntu2.2

    Mettez à jour vers 1.11.0-2ubuntu2.2

Sources originales

Vérifiez votre serveur →