CVE-2023-6349
CVE-2023-6349 · Heap overflow in libvpx
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A heap overflow vulnerability exists in libvpx - Encoding a frame that has larger dimensions than the originally configured size with VP9 may result in a heap overflow in libvpx. We recommend upgrading to version 1.13.1 or above
CVSS 5.7 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libvpx
- Versions
- ≥ 1.5.0, < 1.13.1: Affected (semver)
Update to 1.13.1
libvpx Debian:12
- Versions
- 1.12.0-1
- 1.12.0-1+deb12u1
- Affected ranges
- ECOSYSTEM: < 1.12.0-1+deb12u2
Update to 1.12.0-1+deb12u2
libvpx Debian:13
- Affected ranges
- ECOSYSTEM: < 1.13.1-2
Update to 1.13.1-2
libvpx Debian:14
- Affected ranges
- ECOSYSTEM: < 1.13.1-2
Update to 1.13.1-2
libvpx Ubuntu:Pro:14.04:LTS
- Versions
- 1.2.0-2
- 1.3.0-1
- 1.3.0-2
- 1.3.0-2ubuntu0.1~esm1
- 1.3.0-2ubuntu0.1~esm2
- 1.3.0-2ubuntu0.1~esm3
- 1.3.0-2ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libvpx Ubuntu:Pro:16.04:LTS
- Versions
- 1.4.0-4
- 1.5.0-2
- 1.5.0-2ubuntu1
- 1.5.0-2ubuntu1.1
- 1.5.0-2ubuntu1.1+esm1
- Affected ranges
- ECOSYSTEM: < 1.5.0-2ubuntu1.1+esm2
Update to 1.5.0-2ubuntu1.1+esm2
libvpx Ubuntu:Pro:18.04:LTS
- Versions
- 1.6.1-3
- 1.7.0-3
- 1.7.0-3ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 1.7.0-3ubuntu0.18.04.1+esm1
Update to 1.7.0-3ubuntu0.18.04.1+esm1
libvpx Ubuntu:20.04:LTS
- Versions
- 1.8.1-2
- 1.8.2-1
- 1.8.2-1build1
- Affected ranges
- ECOSYSTEM: < 1.8.2-1ubuntu0.2
Update to 1.8.2-1ubuntu0.2
libvpx Ubuntu:22.04:LTS
- Versions
- 1.9.0-1ubuntu1
- 1.11.0-2ubuntu1
- 1.11.0-2ubuntu2
- Affected ranges
- ECOSYSTEM: < 1.11.0-2ubuntu2.2
Update to 1.11.0-2ubuntu2.2