p PatchFirst

CVE-2023-6349

CVE-2023-6349 · Heap overflow in libvpx

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A heap overflow vulnerability exists in libvpx - Encoding a frame that has larger dimensions than the originally configured size with VP9 may result in a heap overflow in libvpx. We recommend upgrading to version 1.13.1 or above

CVSS 5.7 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libvpx

    Softwareversionen
    • ≥ 1.5.0, < 1.13.1: Betroffen (semver)

    Auf 1.13.1 aktualisieren

  • libvpx Debian:12

    Softwareversionen
    • 1.12.0-1
    • 1.12.0-1+deb12u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.12.0-1+deb12u2

    Auf 1.12.0-1+deb12u2 aktualisieren

  • libvpx Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.13.1-2

    Auf 1.13.1-2 aktualisieren

  • libvpx Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.13.1-2

    Auf 1.13.1-2 aktualisieren

  • libvpx Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.2.0-2
    • 1.3.0-1
    • 1.3.0-2
    • 1.3.0-2ubuntu0.1~esm1
    • 1.3.0-2ubuntu0.1~esm2
    • 1.3.0-2ubuntu0.1~esm3
    • 1.3.0-2ubuntu0.1+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libvpx Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.4.0-4
    • 1.5.0-2
    • 1.5.0-2ubuntu1
    • 1.5.0-2ubuntu1.1
    • 1.5.0-2ubuntu1.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.0-2ubuntu1.1+esm2

    Auf 1.5.0-2ubuntu1.1+esm2 aktualisieren

  • libvpx Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.6.1-3
    • 1.7.0-3
    • 1.7.0-3ubuntu0.18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.7.0-3ubuntu0.18.04.1+esm1

    Auf 1.7.0-3ubuntu0.18.04.1+esm1 aktualisieren

  • libvpx Ubuntu:20.04:LTS

    Softwareversionen
    • 1.8.1-2
    • 1.8.2-1
    • 1.8.2-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.2-1ubuntu0.2

    Auf 1.8.2-1ubuntu0.2 aktualisieren

  • libvpx Ubuntu:22.04:LTS

    Softwareversionen
    • 1.9.0-1ubuntu1
    • 1.11.0-2ubuntu1
    • 1.11.0-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.11.0-2ubuntu2.2

    Auf 1.11.0-2ubuntu2.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →