CVE-2025-59343
CVE-2025-59343 · tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.
CVSS 8.7 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
tar-fs
- Versions du logiciel
- >= 3.0.0, < 3.1.1: Concernée
- >= 2.0.0, < 2.1.3: Concernée
- < 1.16.5: Concernée
Aucun correctif publié
node-tar-fs Debian:12
- Versions du logiciel
- 2.1.1-6
- 2.1.3-0+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 2.1.3-0+deb12u2
Mettez à jour vers 2.1.3-0+deb12u2
node-tar-fs Debian:13
- Versions du logiciel
- 3.0.9+~cs2.0.4-1
- Plages de versions concernées
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1
Mettez à jour vers 3.0.9+~cs2.0.4-1+deb13u1
node-tar-fs Debian:14
- Versions du logiciel
- 3.0.9+~cs2.0.4-1
- Plages de versions concernées
- ECOSYSTEM: < 3.0.9+~cs2.0.4-2
Mettez à jour vers 3.0.9+~cs2.0.4-2
tar-fs npm
- Plages de versions concernées
- SEMVER: ≥ 3.0.0, < 3.1.1
Mettez à jour vers 3.1.1
tar-fs npm
- Plages de versions concernées
- SEMVER: ≥ 2.0.0, < 2.1.4
Mettez à jour vers 2.1.4
tar-fs npm
- Plages de versions concernées
- SEMVER: < 1.16.6
Mettez à jour vers 1.16.6
node-tar-fs Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Plages de versions concernées
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Mettez à jour vers 2.1.1-6ubuntu0.22.04.1~esm1
node-tar-fs Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 2.1.1-6
- Plages de versions concernées
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Mettez à jour vers 2.1.1-6ubuntu0.24.04.1~esm1
node-tar-fs Ubuntu:25.10
- Versions du logiciel
- 2.1.1-6
- 3.0.8+~cs2.0.4-1
- 3.0.9+~cs2.0.4-1
- Plages de versions concernées
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1
Mettez à jour vers 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1