CVE-2025-59343
CVE-2025-59343 · tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.
CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
tar-fs
- Softwareversionen
- >= 3.0.0, < 3.1.1: Betroffen
- >= 2.0.0, < 2.1.3: Betroffen
- < 1.16.5: Betroffen
Keine Korrektur veröffentlicht
node-tar-fs Debian:12
- Softwareversionen
- 2.1.1-6
- 2.1.3-0+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.3-0+deb12u2
Auf 2.1.3-0+deb12u2 aktualisieren
node-tar-fs Debian:13
- Softwareversionen
- 3.0.9+~cs2.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1
Auf 3.0.9+~cs2.0.4-1+deb13u1 aktualisieren
node-tar-fs Debian:14
- Softwareversionen
- 3.0.9+~cs2.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.9+~cs2.0.4-2
Auf 3.0.9+~cs2.0.4-2 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.1.1
Auf 3.1.1 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.1.4
Auf 2.1.4 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: < 1.16.6
Auf 1.16.6 aktualisieren
node-tar-fs Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Auf 2.1.1-6ubuntu0.22.04.1~esm1 aktualisieren
node-tar-fs Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 2.1.1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Auf 2.1.1-6ubuntu0.24.04.1~esm1 aktualisieren
node-tar-fs Ubuntu:25.10
- Softwareversionen
- 2.1.1-6
- 3.0.8+~cs2.0.4-1
- 3.0.9+~cs2.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1
Auf 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1 aktualisieren