p PatchFirst

CVE-2025-59343

CVE-2025-59343 · tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball

This page contains facts from public vulnerability sources. Check the original advisory before updating.

tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.

CVSS 8.7 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • tar-fs

    Versions
    • >= 3.0.0, < 3.1.1: Affected
    • >= 2.0.0, < 2.1.3: Affected
    • < 1.16.5: Affected

    No fix published

  • node-tar-fs Debian:12

    Versions
    • 2.1.1-6
    • 2.1.3-0+deb12u1
    Affected ranges
    • ECOSYSTEM: < 2.1.3-0+deb12u2

    Update to 2.1.3-0+deb12u2

  • node-tar-fs Debian:13

    Versions
    • 3.0.9+~cs2.0.4-1
    Affected ranges
    • ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1

    Update to 3.0.9+~cs2.0.4-1+deb13u1

  • node-tar-fs Debian:14

    Versions
    • 3.0.9+~cs2.0.4-1
    Affected ranges
    • ECOSYSTEM: < 3.0.9+~cs2.0.4-2

    Update to 3.0.9+~cs2.0.4-2

  • tar-fs npm

    Affected ranges
    • SEMVER: ≥ 3.0.0, < 3.1.1

    Update to 3.1.1

  • tar-fs npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.1.4

    Update to 2.1.4

  • tar-fs npm

    Affected ranges
    • SEMVER: < 1.16.6

    Update to 1.16.6

  • node-tar-fs Ubuntu:Pro:22.04:LTS

    Versions
    • 2.1.1-2
    • 2.1.1-4
    • 2.1.1-6
    Affected ranges
    • ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1

    Update to 2.1.1-6ubuntu0.22.04.1~esm1

  • node-tar-fs Ubuntu:Pro:24.04:LTS

    Versions
    • 2.1.1-6
    Affected ranges
    • ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1

    Update to 2.1.1-6ubuntu0.24.04.1~esm1

  • node-tar-fs Ubuntu:25.10

    Versions
    • 2.1.1-6
    • 3.0.8+~cs2.0.4-1
    • 3.0.9+~cs2.0.4-1
    Affected ranges
    • ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1

    Update to 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1

Original sources

Check your server →