p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de yeoman-environment

Vulnérabilité publiée pour yeoman-environment au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilité : 1

  1. CVE-2026-42089

    Élevée · CVSS 8.6EPSS 0,17%Correctif disponible

    yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

    Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

    • Mettez à jour vers 6.0.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →