CVE-2026-75858
CVE-2026-75858 · CodeWhale rlm_eval before 0.8.64 Remote Code Execution
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
CVSS 8.5 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
codewhale
- Versions du logiciel
- ≥ 0.8.33, < 0.8.41: Concernée (semver)
- 0.8.41: Non concernée (semver)
Mettez à jour vers 0.8.41
codewhale
- Versions du logiciel
- ≥ 0.8.41, < 0.8.64: Concernée (semver)
- 0.8.64: Non concernée (semver)
Mettez à jour vers 0.8.64
deepseek-tui crates.io
- Plages de versions concernées
- SEMVER: ≥ 0.8.33, ≤ 0.8.41
Aucun correctif publié
deepseek-tui npm
- Plages de versions concernées
- SEMVER: ≥ 0.8.33, < 0.8.41
Mettez à jour vers 0.8.41
codewhale-tui crates.io
- Plages de versions concernées
- SEMVER: ≥ 0.8.41, < 0.8.64
Mettez à jour vers 0.8.64
codewhale npm
- Plages de versions concernées
- SEMVER: ≥ 0.8.41, < 0.8.64
Mettez à jour vers 0.8.64