CVE-2026-75858
CVE-2026-75858 · CodeWhale rlm_eval before 0.8.64 Remote Code Execution
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
CVSS 8.5 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
codewhale
- Softwareversionen
- ≥ 0.8.33, < 0.8.41: Betroffen (semver)
- 0.8.41: Nicht betroffen (semver)
Auf 0.8.41 aktualisieren
codewhale
- Softwareversionen
- ≥ 0.8.41, < 0.8.64: Betroffen (semver)
- 0.8.64: Nicht betroffen (semver)
Auf 0.8.64 aktualisieren
deepseek-tui crates.io
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.33, ≤ 0.8.41
Keine Korrektur veröffentlicht
deepseek-tui npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.33, < 0.8.41
Auf 0.8.41 aktualisieren
codewhale-tui crates.io
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.41, < 0.8.64
Auf 0.8.64 aktualisieren
codewhale npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.41, < 0.8.64
Auf 0.8.64 aktualisieren