CVE-2026-75858
CVE-2026-75858 · CodeWhale rlm_eval before 0.8.64 Remote Code Execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.
CVSS 8.5 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
codewhale
- Versions
- ≥ 0.8.33, < 0.8.41: Affected (semver)
- 0.8.41: Not affected (semver)
Update to 0.8.41
codewhale
- Versions
- ≥ 0.8.41, < 0.8.64: Affected (semver)
- 0.8.64: Not affected (semver)
Update to 0.8.64
deepseek-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.8.33, ≤ 0.8.41
No fix published
deepseek-tui npm
- Affected ranges
- SEMVER: ≥ 0.8.33, < 0.8.41
Update to 0.8.41
codewhale-tui crates.io
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64
codewhale npm
- Affected ranges
- SEMVER: ≥ 0.8.41, < 0.8.64
Update to 0.8.64