CVE-2026-75913
CVE-2026-75913 · CodeWhale before 0.8.64 Argument Injection via git_show
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
CVSS 8.5 · Élevée · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
codewhale
- Versions du logiciel
- ≥ 0.3.27, ≤ 0.8.41: Concernée (semver)
Aucun correctif publié
codewhale
- Versions du logiciel
- ≥ 0.3.27, < 0.8.41: Concernée (semver)
- 0.8.41: Non concernée (semver)
Mettez à jour vers 0.8.41
codewhale
- Versions du logiciel
- ≥ 0.8.41, < 0.8.64: Concernée (semver)
- 0.8.64: Non concernée (semver)
Mettez à jour vers 0.8.64
deepseek-tui crates.io
- Plages de versions concernées
- SEMVER: ≥ 0.3.27, ≤ 0.8.41
Aucun correctif publié
deepseek-tui npm
- Plages de versions concernées
- SEMVER: ≥ 0.3.27, < 0.8.41
Mettez à jour vers 0.8.41
codewhale-tui crates.io
- Plages de versions concernées
- SEMVER: ≥ 0.8.41, < 0.8.64
Mettez à jour vers 0.8.64
codewhale npm
- Plages de versions concernées
- SEMVER: ≥ 0.8.41, < 0.8.64
Mettez à jour vers 0.8.64