CVE-2026-75913
CVE-2026-75913 · CodeWhale before 0.8.64 Argument Injection via git_show
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
CVSS 8.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
codewhale
- Softwareversionen
- ≥ 0.3.27, ≤ 0.8.41: Betroffen (semver)
Keine Korrektur veröffentlicht
codewhale
- Softwareversionen
- ≥ 0.3.27, < 0.8.41: Betroffen (semver)
- 0.8.41: Nicht betroffen (semver)
Auf 0.8.41 aktualisieren
codewhale
- Softwareversionen
- ≥ 0.8.41, < 0.8.64: Betroffen (semver)
- 0.8.64: Nicht betroffen (semver)
Auf 0.8.64 aktualisieren
deepseek-tui crates.io
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.3.27, ≤ 0.8.41
Keine Korrektur veröffentlicht
deepseek-tui npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.3.27, < 0.8.41
Auf 0.8.41 aktualisieren
codewhale-tui crates.io
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.41, < 0.8.64
Auf 0.8.64 aktualisieren
codewhale npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.8.41, < 0.8.64
Auf 0.8.64 aktualisieren