p PatchFirst

CVE-2026-75913

CVE-2026-75913 · CodeWhale before 0.8.64 Argument Injection via git_show

This page contains facts from public vulnerability sources. Check the original advisory before updating.

CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.

CVSS 8.5 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • codewhale

    Versions
    • ≥ 0.3.27, ≤ 0.8.41: Affected (semver)

    No fix published

  • codewhale

    Versions
    • ≥ 0.3.27, < 0.8.41: Affected (semver)
    • 0.8.41: Not affected (semver)

    Update to 0.8.41

  • codewhale

    Versions
    • ≥ 0.8.41, < 0.8.64: Affected (semver)
    • 0.8.64: Not affected (semver)

    Update to 0.8.64

  • deepseek-tui crates.io

    Affected ranges
    • SEMVER: ≥ 0.3.27, ≤ 0.8.41

    No fix published

  • deepseek-tui npm

    Affected ranges
    • SEMVER: ≥ 0.3.27, < 0.8.41

    Update to 0.8.41

  • codewhale-tui crates.io

    Affected ranges
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Update to 0.8.64

  • codewhale npm

    Affected ranges
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Update to 0.8.64

Original sources

Check your server →