p PatchFirst

PatchFirst · Latest vulnerabilities

yeoman-environment vulnerabilities

Vulnerabilities published for yeoman-environment in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-42089

    High · CVSS 8.6EPSS 0.17%Fix available

    yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

    Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

    • Update to 6.0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →