p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in yeoman-environment

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für yeoman-environment: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücke: 1

  1. CVE-2026-42089

    Hoch · CVSS 8.6EPSS 0,17%Korrektur verfügbar

    yeoman-environment Vulnerable to Arbitrary Package Installation without User Confirmation

    Yeoman Environment provides an API to discover, create, and run generators, and to configure where and how a generator is resolved. Versions 2.9.0 through 6.0.0 install missing local generator packages from caller-supplied package names without user confirmation. In downstream consumers that pass attacker-controlled project configuration into this path, this can result in arbitrary package installation and code execution during CLI bootstrap. The vulnerable method is installLocalGenerators(), which calls repository.install() directly without prompting the user. This issue has been fixed in version 6.0.0.

    • Auf 6.0.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →