p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de setasign/fpdi

Vulnérabilité publiée pour setasign/fpdi au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-45802

    Moyenne · CVSS 6EPSS 0,26%Correctif disponible

    FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

    • Mettez à jour vers 2.6.7
    Publication Mise à jour
  2. CVE-2025-54869

    Moyenne · CVSS 6EPSS 0,33%Correctif disponible

    FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

    FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

    • Mettez à jour vers 2.6.4
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →