ALPINE-CVE-2018-1000168
ALPINE-CVE-2018-1000168
This page contains facts from public vulnerability sources. Check the original advisory before updating.
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nodejs Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0
nodejs Alpine:v3.9
- Affected ranges
- ECOSYSTEM: < 8.11.3-r0
Update to 8.11.3-r0