ALPINE-CVE-2018-8777
ALPINE-CVE-2018-8777
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.4
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.3.7-r0
Update to 2.3.7-r0
ruby Alpine:v3.5
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.3.7-r0
Update to 2.3.7-r0
ruby Alpine:v3.6
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.4.4-r0
Update to 2.4.4-r0
ruby Alpine:v3.7
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.4.4-r0
Update to 2.4.4-r0
ruby Alpine:v3.8
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0
ruby Alpine:v3.9
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0, < 2.5.1-r0
Update to 2.5.1-r0