p PatchFirst

ALPINE-CVE-2022-36760

ALPINE-CVE-2022-36760

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

CVSS 9.0 · Critical · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2 Alpine:v3.14

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.15

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.16

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.17

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.18

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.19

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.20

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

  • apache2 Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 2.4.55-r0

    Update to 2.4.55-r0

Original sources

Check your server →