p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 112

  1. ALPINE-CVE-2026-28780

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2026-28780

    Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

    • Update to 2.4.67-r0
    Published Updated
  2. ALPINE-CVE-2026-29168

    High · CVSS 7.3Fix available

    ALPINE-CVE-2026-29168

    Allocation of Resources Without Limits or Throttling vulnerability in Apache HTTP Server's  mod_md via OCSP response data. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

    • Update to 2.4.67-r0
    Published Updated
  3. ALPINE-CVE-2026-33523

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2026-33523

    HTTP response splitting vulnerability in multiple Apache HTTP Server modules with untrusted or compromised backend servers. This issue affects Apache HTTP Server: from through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

    • Update to 2.4.67-r0
    Published Updated
  4. ALPINE-CVE-2026-33007

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2026-33007

    A NULL pointer dereference in the mod_authn_socache in Apache HTTP Server 2.4.66 and earlier allows an unauthenticated remote user to crash a child process in a caching forward proxy configuration. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

    • Update to 2.4.67-r0
    Published Updated
  5. ALPINE-CVE-2026-29169

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-29169

    A NULL pointer dereference in mod_dav_lock in Apache HTTP Server 2.4.66 and earlier may allow an attacker to crash the server with a malicious request.mod_dav_lock is not used internally by mod_dav or mod_dav_fs. The only known use-case for mod_dav_lock was mod_dav_svn from Apache Subversion earlier than version 1.2.0. Users are recommended to upgrade to version 2.4.66, which fixes this issue, or remove mod_dav_lock.

    • Update to 2.4.67-r0
    Published Updated
  6. ALPINE-CVE-2026-24072

    High · CVSS 8.8Fix available

    ALPINE-CVE-2026-24072

    An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

    • Update to 2.4.67-r0
    Published Updated
  7. ALPINE-CVE-2025-58098

    High · CVSS 8.3Fix available

    ALPINE-CVE-2025-58098

    Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Update to 2.4.66-r0
    Published Updated
  8. ALPINE-CVE-2025-66200

    Medium · CVSS 5.4Fix available

    ALPINE-CVE-2025-66200

    mod_userdir+suexec bypass via AllowOverride FileInfo vulnerability in Apache HTTP Server. Users with access to use the RequestHeader directive in htaccess can cause some CGI scripts to run under an unexpected userid. This issue affects Apache HTTP Server: from 2.4.7 through 2.4.65. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Update to 2.4.66-r0
    Published Updated
  9. ALPINE-CVE-2025-65082

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2025-65082

    Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

    • Update to 2.4.66-r0
    Published Updated
  10. ALPINE-CVE-2025-59775

    High · CVSS 7.5Fix available

    ALPINE-CVE-2025-59775

    Server-Side Request Forgery (SSRF) vulnerability  in Apache HTTP Server on Windows with AllowEncodedSlashes On and MergeSlashes Off  allows to potentially leak NTLM hashes to a malicious server via SSRF and malicious requests or content Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Update to 2.4.66-r0
    Published Updated
  11. ALPINE-CVE-2025-55753

    High · CVSS 7.5Fix available

    ALPINE-CVE-2025-55753

    An integer overflow in the case of failed ACME certificate renewal leads, after a number of failures (~30 days in default configurations), to the backoff timer becoming 0. Attempts to renew the certificate then are repeated without delays until it succeeds. This issue affects Apache HTTP Server: from 2.4.30 before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

    • Update to 2.4.66-r0
    Published Updated
  12. ALPINE-CVE-2025-49812

    High · CVSS 7.4Fix available

    ALPINE-CVE-2025-49812

    In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.

    • Update to 2.4.64-r0
    Published Updated
  13. ALPINE-CVE-2025-49630

    High · CVSS 7.5Fix available

    ALPINE-CVE-2025-49630

    In certain proxy configurations, a denial of service attack against Apache HTTP Server versions 2.4.26 through to 2.4.63 can be triggered by untrusted clients causing an assertion in mod_proxy_http2. Configurations affected are a reverse proxy is configured for an HTTP/2 backend, with ProxyPreserveHost set to "on".

    • Update to 2.4.64-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →