ALPINE-CVE-2025-27219
ALPINE-CVE-2025-27219
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 3.2.8-r0
Update to 3.2.8-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 3.3.8-r0
Update to 3.3.8-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 3.3.8-r0
Update to 3.3.8-r0
ruby-net-imap Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 0.3.9-r0
Update to 0.3.9-r0
ruby-net-imap Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 0.4.19-r0
Update to 0.4.19-r0
ruby-net-imap Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 0.4.19-r0
Update to 0.4.19-r0