p PatchFirst

PatchFirst · Latest vulnerabilities

ruby-net-imap vulnerabilities

Vulnerabilities published for ruby-net-imap in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. ALPINE-CVE-2025-27219

    High · CVSS 7.5Fix available

    ALPINE-CVE-2025-27219

    In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.

    • Update to 0.3.9-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →