p PatchFirst

PatchFirst · Latest vulnerabilities

ruby-net-imap vulnerabilities

Vulnerabilities published for ruby-net-imap in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. ALPINE-CVE-2025-43857

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2025-43857

    Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.5.7, 0.4.20, 0.3.9, and 0.2.5, there is a possibility for denial of service by memory exhaustion when net-imap reads server responses. At any time while the client is connected, a malicious server can send can send a "literal" byte count, which is automatically read by the client's receiver thread. The response reader immediately allocates memory for the number of bytes indicated by the server response. This should not be an issue when securely connecting to trusted IMAP servers that are well-behaved. It can affect insecure connectio

    • Update to 0.4.22-r0
    Published Updated
  2. ALPINE-CVE-2025-27219

    High · CVSS 7.5Fix available

    ALPINE-CVE-2025-27219

    In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.

    • Update to 0.4.19-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →