ALPINE-CVE-2025-49630
ALPINE-CVE-2025-49630
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In certain proxy configurations, a denial of service attack against Apache HTTP Server versions 2.4.26 through to 2.4.63 can be triggered by untrusted clients causing an assertion in mod_proxy_http2. Configurations affected are a reverse proxy is configured for an HTTP/2 backend, with ProxyPreserveHost set to "on".
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.64-r0
Update to 2.4.64-r0