p PatchFirst

ALPINE-CVE-2026-34355

ALPINE-CVE-2026-34355

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A buffer overflow in mod_proxy_html in Apache HTTP Server 2.4.67 and earlier allows an attack by an untrusted backend. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2 Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 2.4.68-r0

    Update to 2.4.68-r0

  • apache2 Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.4.68-r0

    Update to 2.4.68-r0

  • apache2 Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.4.68-r0

    Update to 2.4.68-r0

  • apache2 Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 2.4.68-r0

    Update to 2.4.68-r0

Original sources

Check your server →