p PatchFirst

ALPINE-CVE-2026-42258

ALPINE-CVE-2026-42258

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

CVSS 5.3 · Medium · Fix available

Published
Updated

Stack: system

Affected products and versions

  • ruby-net-imap Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 0.4.25-r0

    Update to 0.4.25-r0

Original sources

Check your server →