p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 4

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. ALPINE-CVE-2017-9798

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-9798

    Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.

    • Update to 2.4.27-r1
    Published Updated
  2. ALPINE-CVE-2017-7668

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-7668

    The HTTP strict parsing changes added in Apache httpd 2.2.32 and 2.4.24 introduced a bug in token list parsing, which allows ap_find_token() to search past the end of its input string. By maliciously crafting a sequence of request headers, an attacker may be able to cause a segmentation fault, or to force ap_find_token() to return an incorrect value.

    • Update to 2.4.26-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →