p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. ALPINE-CVE-2022-31813

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2022-31813

    Apache HTTP Server 2.4.53 and earlier may not send the X-Forwarded-* headers to the origin server based on client side Connection header hop-by-hop mechanism. This may be used to bypass IP based authentication on the origin server/application.

    • Update to 2.4.54-r0
    Published Updated
  2. ALPINE-CVE-2022-28615

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2022-28615

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    • Update to 2.4.54-r0
    Published Updated
  3. ALPINE-CVE-2022-28614

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2022-28614

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    • Update to 2.4.54-r0
    Published Updated
  4. ALPINE-CVE-2022-26377

    High · CVSS 7.5Fix available

    ALPINE-CVE-2022-26377

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    • Update to 2.4.54-r0
    Published Updated
  5. ALPINE-CVE-2022-22721

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2022-22721

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    • Update to 2.4.53-r0
    Published Updated
  6. ALPINE-CVE-2021-44790

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-44790

    A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

    • Update to 2.4.52-r0
    Published Updated
  7. ALPINE-CVE-2021-44224

    High · CVSS 8.2Fix available

    ALPINE-CVE-2021-44224

    A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

    • Update to 2.4.52-r0
    Published Updated
  8. ALPINE-CVE-2021-42013

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-42013

    It was found that the fix for CVE-2021-41773 in Apache HTTP Server 2.4.50 was insufficient. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue only affects Apache 2.4.49 and Apache 2.4.50 and not earlier versions.

    • Update to 2.4.51-r0
    Published Updated
  9. ALPINE-CVE-2021-41773

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-41773

    A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42

    • Update to 2.4.50-r0
    Published Updated
  10. ALPINE-CVE-2021-41524

    High · CVSS 7.5Fix available

    ALPINE-CVE-2021-41524

    While fuzzing the 2.4.49 httpd, a new null pointer dereference was detected during HTTP/2 request processing, allowing an external source to DoS the server. This requires a specially crafted request. The vulnerability was recently introduced in version 2.4.49. No exploit is known to the project.

    • Update to 2.4.50-r0
    Published Updated
  11. ALPINE-CVE-2021-39275

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-39275

    ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.

    • Update to 2.4.49-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →