p PatchFirst

CVE-2014-0061

CVE-2014-0061

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The validator functions for the procedural languages (PLs) in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to gain privileges via a function that is (1) defined in another language or (2) not allowed to be directly called by the user due to permissions.

EPSS 4.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • postgresql-plsh Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.20140221-1

    Update to 1.20140221-1

  • postgresql-plsh Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.20140221-1

    Update to 1.20140221-1

  • postgresql-plsh Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.20140221-1

    Update to 1.20140221-1

  • postgresql-9.1 Ubuntu:14.04:LTS

    Versions
    • 9.1.10-1
    • 9.1.10-1bzr1
    • 9.1.11-1
    • 9.1.11-2
    Affected ranges
    • ECOSYSTEM: < 9.1.12-1

    Update to 9.1.12-1

  • postgresql-9.3 Ubuntu:14.04:LTS

    Versions
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 9.3.3-1

    Update to 9.3.3-1

Original sources

Check your server →