p PatchFirst

CVE-2014-0224

CVE-2014-0224

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly restrict processing of ChangeCipherSpec messages, which allows man-in-the-middle attackers to trigger use of a zero-length master key in certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions or obtain sensitive information, via a crafted TLS handshake, aka the "CCS Injection" vulnerability.

CVSS 7.4 · High · EPSS 95.3% · Public exploit · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.1h-1

    Update to 1.0.1h-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.1h-1

    Update to 1.0.1h-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.1h-1

    Update to 1.0.1h-1

  • openssl Ubuntu:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.2

    Update to 1.0.1f-1ubuntu2.2

  • openssl098 Ubuntu:14.04:LTS

    Versions
    • 0.9.8o-7ubuntu3.1
    Affected ranges
    • ECOSYSTEM: < 0.9.8o-7ubuntu3.2.14.04.1

    Update to 0.9.8o-7ubuntu3.2.14.04.1

Original sources

Check your server →