p PatchFirst

PatchFirst · Latest vulnerabilities

openssl098 vulnerabilities

Vulnerabilities published for openssl098 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2014-0224

    High · CVSS 7.4EPSS 95.33%Public exploitFix available

    CVE-2014-0224

    OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly restrict processing of ChangeCipherSpec messages, which allows man-in-the-middle attackers to trigger use of a zero-length master key in certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions or obtain sensitive information, via a crafted TLS handshake, aka the "CCS Injection" vulnerability.

    • Update to 0.9.8o-7ubuntu3.2.14.04.1
    Published Updated
  2. CVE-2014-0195

    Not ratedEPSS 99.98%Public exploitFix available

    CVE-2014-0195

    The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly validate fragment lengths in DTLS ClientHello messages, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a long non-initial fragment.

    • Update to 0.9.8o-7ubuntu3.2.14.04.1
    Published Updated
  3. CVE-2013-0169

    Not ratedEPSS 35.58%Fix available

    CVE-2013-0169

    The TLS protocol 1.1 and 1.2 and the DTLS protocol 1.0 and 1.2, as used in OpenSSL, OpenJDK, PolarSSL, and other products, do not properly consider timing side-channel attacks on a MAC check requirement during the processing of malformed CBC padding, which allows remote attackers to conduct distinguishing attacks and plaintext-recovery attacks via statistical analysis of timing data for crafted packets, aka the "Lucky Thirteen" issue.

    • Update to 0.9.8o-7ubuntu3.2.14.04.1
    Published Updated
  4. CVE-2012-2333

    Not ratedEPSS 27.87%Fix available

    CVE-2012-2333

    Integer underflow in OpenSSL before 0.9.8x, 1.0.0 before 1.0.0j, and 1.0.1 before 1.0.1c, when TLS 1.1, TLS 1.2, or DTLS is used with CBC encryption, allows remote attackers to cause a denial of service (buffer over-read) or possibly have unspecified other impact via a crafted TLS packet that is not properly handled during a certain explicit IV calculation.

    • Update to 0.9.8o-7ubuntu3.2.14.04.1
    Published Updated
  5. CVE-2012-0884

    Not ratedEPSS 13.18%Fix available

    CVE-2012-0884

    The implementation of Cryptographic Message Syntax (CMS) and PKCS #7 in OpenSSL before 0.9.8u and 1.x before 1.0.0h does not properly restrict certain oracle behavior, which makes it easier for context-dependent attackers to decrypt data via a Million Message Attack (MMA) adaptive chosen ciphertext attack.

    • Update to 0.9.8o-7ubuntu3.2.14.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →