CVE-2015-8476
CVE-2015-8476
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to inject arbitrary SMTP commands via CRLF sequences in an (1) email address to the validateAddress function in class.phpmailer.php or (2) SMTP command to the sendCommand function in class.smtp.php, a different vulnerability than CVE-2012-0796.
EPSS 2.0% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libphp-phpmailer Debian:12
- Affected ranges
- ECOSYSTEM: < 5.2.14+dfsg-1
Update to 5.2.14+dfsg-1
libphp-phpmailer Debian:13
- Affected ranges
- ECOSYSTEM: < 5.2.14+dfsg-1
Update to 5.2.14+dfsg-1
libphp-phpmailer Debian:14
- Affected ranges
- ECOSYSTEM: < 5.2.14+dfsg-1
Update to 5.2.14+dfsg-1
phpmailer/phpmailer Packagist
- Versions
- v5.2.10
- v5.2.11
- v5.2.12
- v5.2.13
- v5.2.2
- v5.2.4
- v5.2.5
- v5.2.6
- v5.2.7
- v5.2.8
- v5.2.9
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0, < 5.2.14
Update to 5.2.14
libphp-phpmailer Ubuntu:14.04:LTS
- Versions
- 5.1-1
- Affected ranges
- ECOSYSTEM: < 5.1-1+deb6u11build0.14.04.1
Update to 5.1-1+deb6u11build0.14.04.1
Original sources
- https://github.com/PHPMailer/PHPMailer/commit/6687a96a18b8f12148881e4ddde795ae477284b0
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177139.html
- http://www.openwall.com/lists/oss-security/2015/12/05/1
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.14
- http://www.debian.org/security/2015/dsa-3416
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177130.html
- http://www.securityfocus.com/bid/78619
- http://www.openwall.com/lists/oss-security/2015/12/04/5
- https://nvd.nist.gov/vuln/detail/CVE-2015-8476