p PatchFirst

CVE-2016-10033

CVE-2016-10033

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.

CVSS 9.8 · Critical · EPSS 99.7% · In KEV · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-phpmailer Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.1

    Update to 5.2.14+dfsg-2.1

  • libphp-phpmailer Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.1

    Update to 5.2.14+dfsg-2.1

  • libphp-phpmailer Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-2.1

    Update to 5.2.14+dfsg-2.1

  • phpmailer/phpmailer Packagist

    Versions
    • v5.2.10
    • v5.2.11
    • v5.2.12
    • v5.2.13
    • v5.2.14
    • v5.2.15
    • v5.2.16
    • v5.2.17
    • v5.2.2
    • v5.2.4
    • v5.2.5
    • v5.2.6
    • v5.2.7
    • v5.2.8
    • v5.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0, < 5.2.18

    Update to 5.2.18

  • libphp-phpmailer Ubuntu:Pro:16.04:LTS

    Versions
    • 5.2.10+dfsg-1
    • 5.2.14+dfsg-1
    • 5.2.14+dfsg-1build1
    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-1ubuntu0.1~esm1

    Update to 5.2.14+dfsg-1ubuntu0.1~esm1

Original sources

Check your server →