p PatchFirst

PatchFirst · Latest vulnerabilities

libphp-phpmailer vulnerabilities

Vulnerabilities published for libphp-phpmailer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2017-5223

    Medium · CVSS 5.5EPSS 2.14%Public exploitFix available

    CVE-2017-5223

    An issue was discovered in PHPMailer before 5.2.22. PHPMailer's msgHTML method applies transformations to an HTML document to make it usable as an email message body. One of the transformations is to convert relative image URLs into attachments using a script-provided base directory. If no base directory is provided, it resolves to /, meaning that relative image URLs get treated as absolute local file paths and added as attachments. To form a remote vulnerability, the msgHTML method must be called, passed an unfiltered, user-supplied HTML document, and must not set a base directory.

    • Update to 5.2.14+dfsg-1ubuntu0.1~esm1
    Published Updated
  2. CVE-2016-10045

    Critical · CVSS 9.8EPSS 97.74%Public exploitFix available

    CVE-2016-10045

    The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.

    • Update to 5.2.14+dfsg-1ubuntu0.1~esm1
    Published Updated
  3. CVE-2016-10033

    Critical · CVSS 9.8EPSS 99.71%In KEVPublic exploitFix available

    CVE-2016-10033

    The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.

    • Update to 5.2.14+dfsg-1ubuntu0.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →