p PatchFirst

CVE-2016-10045

CVE-2016-10045

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.

CVSS 9.8 · Critical · EPSS 97.7% · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • phpmailer/phpmailer Packagist

    Versions
    • v5.2.10
    • v5.2.11
    • v5.2.12
    • v5.2.13
    • v5.2.14
    • v5.2.15
    • v5.2.16
    • v5.2.17
    • v5.2.18
    • v5.2.19
    • v5.2.2
    • v5.2.4
    • v5.2.5
    • v5.2.6
    • v5.2.7
    • v5.2.8
    • v5.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0, < 5.2.20

    Update to 5.2.20

  • libphp-phpmailer Ubuntu:Pro:16.04:LTS

    Versions
    • 5.2.10+dfsg-1
    • 5.2.14+dfsg-1
    • 5.2.14+dfsg-1build1
    Affected ranges
    • ECOSYSTEM: < 5.2.14+dfsg-1ubuntu0.1~esm1

    Update to 5.2.14+dfsg-1ubuntu0.1~esm1

Original sources

Check your server →