CVE-2016-10164
CVE-2016-10164
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer overflows in libXpm before 3.5.12, when a program requests parsing XPM extensions on a 64-bit platform, allow remote attackers to cause a denial of service (out-of-bounds write) or execute arbitrary code via (1) the number of extensions or (2) their concatenated length in a crafted XPM file, which triggers a heap-based buffer overflow.
CVSS 9.8 · Critical · EPSS 7.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libxpm Debian:12
- Affected ranges
- ECOSYSTEM: < 1:3.5.12-1
Update to 1:3.5.12-1
libxpm Debian:13
- Affected ranges
- ECOSYSTEM: < 1:3.5.12-1
Update to 1:3.5.12-1
libxpm Debian:14
- Affected ranges
- ECOSYSTEM: < 1:3.5.12-1
Update to 1:3.5.12-1
libxpm Ubuntu:14.04:LTS
- Versions
- 1:3.5.10-1
- Affected ranges
- ECOSYSTEM: < 1:3.5.10-1ubuntu0.1
Update to 1:3.5.10-1ubuntu0.1
libxpm Ubuntu:16.04:LTS
- Versions
- 1:3.5.11-1
- Affected ranges
- ECOSYSTEM: < 1:3.5.11-1ubuntu0.16.04.1
Update to 1:3.5.11-1ubuntu0.16.04.1
Original sources
- http://www.openwall.com/lists/oss-security/2017/01/25/7
- https://lists.freedesktop.org/archives/xorg/2016-December/058537.html
- http://www.openwall.com/lists/oss-security/2017/01/22/2
- http://www.securityfocus.com/bid/95785
- https://cgit.freedesktop.org/xorg/lib/libXpm/commit/?id=d1167418f0fd02a27f617ec5afd6db053afbe185
- https://access.redhat.com/errata/RHSA-2017:1865
- http://www.debian.org/security/2017/dsa-3772
- https://security.gentoo.org/glsa/201701-72
- https://nvd.nist.gov/vuln/detail/CVE-2016-10164