p PatchFirst

PatchFirst · Latest vulnerabilities

libxpm vulnerabilities

Vulnerability published for libxpm in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. CVE-2026-94287

    Medium · CVSS 5.5EPSS 0.13%No fix published

    Denial of service via unsigned underflow in libXpm's write path

    A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.

    Published Updated
  2. CVE-2026-4367

    Medium · CVSS 5.5EPSS 0.13%No fix published

    Libxpm: libxpm: denial of service via out-of-bounds read in xpm file parsing

    A flaw was found in libXpm. A local user with low privileges could exploit an Out-of-Bounds Read vulnerability in the `xpmNextWord()` function by processing a specially crafted or very small XPM (X PixMap) image file. This improper validation of file boundaries can cause an internal pointer to read beyond the file's end, leading to application crashes and Denial of Service conditions.

    Published Updated
  3. CVE-2023-43788

    Medium · CVSS 5.5EPSS 0.38%Fix available

    Libxpm: out of bounds read in xpmcreatexpmimagefrombuffer()

    A vulnerability was found in libXpm due to a boundary condition within the XpmCreateXpmImageFromBuffer() function. This flaw allows a local attacker to trigger an out-of-bounds read error and read the contents of memory on the system.

    • Update to 1:3.5.12-1.1+deb12u1
    Published Updated
  4. CVE-2022-4883

    High · CVSS 8.8EPSS 1.2%Fix available

    CVE-2022-4883

    A flaw was found in libXpm. When processing files with .Z or .gz extensions, the library calls external programs to compress and uncompress files, relying on the PATH environment variable to find these programs, which could allow a malicious user to execute other programs by manipulating the PATH environment variable.

    • Update to 1:3.5.12-1.1
    Published Updated
  5. CVE-2016-10164

    Critical · CVSS 9.8EPSS 7.59%Fix available

    CVE-2016-10164

    Multiple integer overflows in libXpm before 3.5.12, when a program requests parsing XPM extensions on a 64-bit platform, allow remote attackers to cause a denial of service (out-of-bounds write) or execute arbitrary code via (1) the number of extensions or (2) their concatenated length in a crafted XPM file, which triggers a heap-based buffer overflow.

    • Update to 1:3.5.12-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →