p PatchFirst

CVE-2016-1234

CVE-2016-1234

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Stack-based buffer overflow in the glob implementation in GNU C Library (aka glibc) before 2.24, when GLOB_ALTDIRFUNC is used, allows context-dependent attackers to cause a denial of service (crash) via a long name.

CVSS 7.5 · High · EPSS 5.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.22-8

    Update to 2.22-8

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.22-8

    Update to 2.22-8

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.22-8

    Update to 2.22-8

  • eglibc Ubuntu:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    Affected ranges
    • ECOSYSTEM: < 2.19-0ubuntu6.10

    Update to 2.19-0ubuntu6.10

  • glibc Ubuntu:16.04:LTS

    Versions
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    Affected ranges
    • ECOSYSTEM: < 2.23-0ubuntu6

    Update to 2.23-0ubuntu6

Original sources

Check your server →