p PatchFirst

CVE-2016-7798

CVE-2016-7798

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.

CVSS 7.5 · High · EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ruby-attr-encrypted Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.1-2

    Update to 3.0.1-2

  • ruby-attr-encrypted Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.1-2

    Update to 3.0.1-2

  • ruby-attr-encrypted Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.1-2

    Update to 3.0.1-2

  • ruby-encryptor Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.0-1

    Update to 3.0.0-1

  • ruby-encryptor Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.0-1

    Update to 3.0.0-1

  • ruby-encryptor Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.0-1

    Update to 3.0.0-1

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versions
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.3

    Update to 1.9.3.484-2ubuntu1.3

  • ruby2.0 Ubuntu:14.04:LTS

    Versions
    • 2.0.0.299-2
    • 2.0.0.343-1
    • 2.0.0.343-1ubuntu1
    • 2.0.0.353-1
    • 2.0.0.353-1ubuntu1
    • 2.0.0.484-1ubuntu1
    • 2.0.0.484-1ubuntu2
    • 2.0.0.484-1ubuntu2.1
    • 2.0.0.484-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 2.0.0.484-1ubuntu2.4

    Update to 2.0.0.484-1ubuntu2.4

  • ruby2.3 Ubuntu:16.04:LTS

    Versions
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    Affected ranges
    • ECOSYSTEM: < 2.3.1-2~16.04.2

    Update to 2.3.1-2~16.04.2

  • ruby-attr-encrypted Ubuntu:16.04:LTS

    Versions
    • 1.3.4-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ruby-encryptor Ubuntu:16.04:LTS

    Versions
    • 1.3.0-1
    • 2.0.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →