p PatchFirst

CVE-2016-7979

CVE-2016-7979

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ghostscript before 9.21 might allow remote attackers to bypass the SAFER mode protection mechanism and consequently execute arbitrary code by leveraging type confusion in .initialize_dsc_parser.

CVSS 9.8 · Critical · EPSS 6.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 9.19~dfsg-3.1

    Update to 9.19~dfsg-3.1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 9.19~dfsg-3.1

    Update to 9.19~dfsg-3.1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 9.19~dfsg-3.1

    Update to 9.19~dfsg-3.1

  • ghostscript Ubuntu:14.04:LTS

    Versions
    • 9.10~dfsg-0ubuntu2
    • 9.10~dfsg-0ubuntu3
    • 9.10~dfsg-0ubuntu4
    • 9.10~dfsg-0ubuntu5
    • 9.10~dfsg-0ubuntu6
    • 9.10~dfsg-0ubuntu7
    • 9.10~dfsg-0ubuntu8
    • 9.10~dfsg-0ubuntu9
    • 9.10~dfsg-0ubuntu10
    • 9.10~dfsg-0ubuntu10.1
    • 9.10~dfsg-0ubuntu10.2
    • 9.10~dfsg-0ubuntu10.3
    • 9.10~dfsg-0ubuntu10.4
    Affected ranges
    • ECOSYSTEM: < 9.10~dfsg-0ubuntu10.5

    Update to 9.10~dfsg-0ubuntu10.5

  • ghostscript Ubuntu:16.04:LTS

    Versions
    • 9.16~dfsg~0-0ubuntu3
    • 9.16~dfsg~0-0ubuntu4
    • 9.18~dfsg~0-0ubuntu1
    • 9.18~dfsg~0-0ubuntu2
    Affected ranges
    • ECOSYSTEM: < 9.18~dfsg~0-0ubuntu2.2

    Update to 9.18~dfsg~0-0ubuntu2.2

Original sources

Check your server →