p PatchFirst

CVE-2016-9577

CVE-2016-9577

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.

CVSS 7.5 · High · EPSS 3.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • spice

    Versions
    • 0.13.90: Affected

    No fix published

  • spice Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.1

    Update to 0.12.8-2.1

  • spice Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.1

    Update to 0.12.8-2.1

  • spice Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.12.8-2.1

    Update to 0.12.8-2.1

  • spice Ubuntu:14.04:LTS

    Versions
    • 0.12.4-0nocelt1
    • 0.12.4-0nocelt1.1
    • 0.12.4-0nocelt1.1ubuntu1
    • 0.12.4-0nocelt2
    • 0.12.4-0nocelt2ubuntu1
    • 0.12.4-0nocelt2ubuntu1.1
    • 0.12.4-0nocelt2ubuntu1.2
    • 0.12.4-0nocelt2ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 0.12.4-0nocelt2ubuntu1.4

    Update to 0.12.4-0nocelt2ubuntu1.4

  • spice Ubuntu:16.04:LTS

    Versions
    • 0.12.5-1.1ubuntu2
    • 0.12.6-4
    • 0.12.6-4ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 0.12.6-4ubuntu0.2

    Update to 0.12.6-4ubuntu0.2

Original sources

Check your server →