p PatchFirst

PatchFirst · Latest vulnerabilities

spice vulnerabilities

Vulnerabilities published for spice in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2018-10873

    High · CVSS 8.3EPSS 3.93%Fix available

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Update to 0.12.4-0nocelt2ubuntu1.7
    Published Updated
  2. CVE-2017-12194

    Critical · CVSS 9.8EPSS 5.25%Fix available

    CVE-2017-12194

    A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

    • Update to 0.12.4-0nocelt2ubuntu1.6
    Published Updated
  3. CVE-2015-3247

    Not ratedEPSS 1.14%Fix available

    CVE-2015-3247

    Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.

    • Update to 0.12.4-0nocelt2ubuntu1.1
    Published Updated
  4. CVE-2013-4130

    Not ratedEPSS 2.63%Fix available

    CVE-2013-4130

    The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.

    • Update to 0.12.4-0nocelt1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →