p PatchFirst

PatchFirst · Latest vulnerabilities

spice vulnerabilities

Vulnerabilities published for spice in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 17

  1. CVE-2026-105958

    High · CVSS 7.5EPSS 0.25%No fix published

    Spice-server: spice: heap oob read/write via unchecked migration data offsets

    A flaw was found in spice-server. Multiple migration data handlers use client-supplied offsets from SPICE_MSGC_MIGRATE_DATA messages without bounds validation, allowing a malicious authenticated SPICE client during VM live migration to read arbitrary heap memory or trigger heap corruption via out-of-bounds read and write operations on the message buffer.

    Published Updated
  2. CVE-2026-105959

    High · CVSS 7.5EPSS 0.48%No fix published

    Spice-server: spice: heap buffer overflow via glz dictionary max_encoders integer truncation

    A flaw was found in spice-server. The GLZ encoder dictionary restore path truncates a size_t allocation size to int when calling the malloc callback, allowing a malicious authenticated SPICE client during VM live migration to trigger a massive heap buffer overflow by sending a crafted max_encoders value in migration data.

    Published Updated
  3. CVE-2020-23793

    High · CVSS 8.6EPSS 0.84%Fix available

    CVE-2020-23793

    An issue was discovered in spice-server spice-server-0.14.0-6.el7_6.1.x86_64 of Redhat's VDI product. There is a security vulnerablility that can restart KVMvirtual machine without any authorization. It is not yet known if there will be other other effects.

    • Update to 0.13.90-0.1
    Published Updated
  4. CVE-2020-14355

    Medium · CVSS 6.6EPSS 2.66%Fix available

    CVE-2020-14355

    Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1. Both the SPICE client (spice-gtk) and server are affected by these flaws. These flaws allow a malicious client or server to send specially crafted messages that, when processed by the QUIC image compression algorithm, result in a process crash or potential code execution.

    • Update to 0.14.3-2
    Published Updated
  5. CVE-2018-10873

    High · CVSS 8.3EPSS 3.93%Fix available

    CVE-2018-10873

    A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

    • Update to 0.14.0-1.1
    Published Updated
  6. CVE-2013-4130

    Not ratedEPSS 2.63%Fix available

    CVE-2013-4130

    The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might allow remote attackers to cause a denial of service (reachable assertion and server exit) by triggering a network error.

    • Update to 0.12.4-0nocelt1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →