p PatchFirst

CVE-2017-0900

CVE-2017-0900

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

CVSS 7.5 · High · EPSS 8.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rubygems Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • ruby1.9.1 Ubuntu:14.04:LTS

    Versions
    • 1.9.3.194-8.1ubuntu2
    • 1.9.3.448-1ubuntu1
    • 1.9.3.448-1ubuntu2
    • 1.9.3.484-1ubuntu1
    • 1.9.3.484-1ubuntu2
    • 1.9.3.484-2ubuntu1
    • 1.9.3.484-2ubuntu1.1
    • 1.9.3.484-2ubuntu1.2
    • 1.9.3.484-2ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1.9.3.484-2ubuntu1.5

    Update to 1.9.3.484-2ubuntu1.5

  • jruby Ubuntu:Pro:14.04:LTS

    Versions
    • 1.5.6-5ubuntu1
    • 1.5.6-6
    • 1.5.6-7
    • 1.5.6-9+deb8u2build0.14.04.1~esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ruby2.3 Ubuntu:16.04:LTS

    Versions
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    Affected ranges
    • ECOSYSTEM: < 2.3.1-2~16.04.6

    Update to 2.3.1-2~16.04.6

  • jruby Ubuntu:16.04:LTS

    Versions
    • 1.7.21-2ubuntu4
    • 1.7.22-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:18.04:LTS

    Versions
    • 9.1.13.0-1
    • 9.1.17.0-1~18.04
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:20.04:LTS

    Versions
    • 9.1.17.0-3
    • 9.1.17.0-3build5
    • 9.1.17.0-3build6
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:24.04:LTS

    Versions
    • 9.3.9.0+ds-1
    • 9.4.5.0+ds-1
    • 9.4.5.0+ds-1ubuntu1
    • 9.4.6.0+ds-1ubuntu3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:25.10

    Versions
    • 9.4.8.0+ds-2ubuntu1
    • 9.4.8.0+ds-3ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:26.10

    Versions
    • 9.4.8.0+ds-3ubuntu1
    • 9.4.14.0+ds-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jruby Ubuntu:26.04:LTS

    Versions
    • 9.4.8.0+ds-3ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →